Remmina 1.2.0-rcgit.9 has been released!

This is a quite interesting release, featuring, mainly, the Autoreconnect for the RDP protocol.

Starting from this year, we will dedicate each version to special users, contributors or projects that contributed directly or indirectly to the Remmina  development.

This release is dedicated to our first donors:

  • Daniel Bolter
  • Richard Pendlebury
  • Michael Gruben
  • Gustavo Uceda
  • Paul Johnson
  • Nic Galler
  • Viktor Sik

Change Log

1.2.0-rcgit.9 (2016-02-28)

Full Changelog

Fixed bugs:

Closed issues:

  • Share some usage statistics dialog cannot be disabled!!! #772
  • vnc plugin not found #768
  • Selected file after editing is wrong #761
  • SSH cursor and scrolling / display issues #760
  • NumLock in RDP sessions #758
  • Buttons not shown inside RDP Advanced tab on smal screens #757
  • Can’t SSH tunnel over Remmina (RDP) #756
  • Remmina closes unexpectedly #753
  • Feature Request: After Command (opposite to precommand) #746
  • mistake. #739
  • Currently rdp_event.c.o can not be built #732
  • Scrolled fullscreen mode does not work #729
  • RDP session is dropped from time to time, reproducible situation. #723
  • RDP plugin fails to load #721
  • [Info Req] RDP v7 #719
  • Suddenly fails to RDP to any server #717
  • Constantly and often breaks the connection. It started about 1-2 months ago. #710
  • No RDP connection after latest update Ubuntu #657
  • Fullscreen windows open on the monitor next to them #580
  • fullscreen multiple screens #577
  • Missing controls tab from top/center of window in Gnome #481
  • ALT + F4 closes Remina remote Window #125

Merged pull requests:

 

10 thoughts on “Remmina 1.2.0-rcgit.9 has been released!

  • Dear Sirs,
    For some reason your application (I have the latest update) does not what xfreerdp is able to do: start a rdp session from Mint 17.3 desktop to Win 2012 client pc. I use rdp-files from previous sessions from a local win7 pc. These work with xfreerdp, but not with remmina. Is it not supposed to work or is something else wrong ?

  • I am following through the procedure to compile the “next” branch on my Centos 7. I get to compile Remmina 1.2.0-rcgit.8 but is receiving error with this particular update. Hope you can help me.

    Command:
    cmake -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX:PATH=/opt/remmina_devel/remmina -DCMAKE_PREFIX_PATH=/opt/remmina_devel/freerdp –build=build .

    Error:

    — Found GTK3: /usr/lib64/libgtk-3.so
    — Finding suggested package ZLIB.
    — Disable this using “-DWITH_ZLIB=OFF”.
    — Found ZLIB: /usr/lib64/libz.so (found version “1.2.7”)
    — Found LIBSECRET: /usr/include/libsecret-1;/usr/include/glib-2.0;/usr/lib64/glib-2.0/include
    CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
    Please set them or make sure they are set and tested correctly in the CMake files:
    WINPR_INCLUDE_DIR
    used as include directory in directory /root/remmina-devel-rcgit9/Remmina/remmina-plugins/rdp

    — Configuring incomplete, errors occurred!

    Thanks!

      • Hi Antenore!

        Yes, I followed it carefully. I am able to compile Remmina 1.2.0-rcgit.8 but cannot do the same for this release. I also tried it to different workstation still with the same error. Please help.

          • Hi Antenore,

            Here it is!

            [~]$ rpm -qa | grep -e remmina -e freerdp
            freerdp-1.0.2-6.el7_2.1.x86_64
            freerdp-libs-1.0.2-6.el7_2.1.x86_64
            freerdp-plugins-1.0.2-6.el7_2.1.x86_64

            [~]$ xfreerdp –version
            This is FreeRDP version 2.0.0-dev (git cf6ea23)

            [~]$ ldd `which xfreerdp`
            linux-vdso.so.1 => (0x00007ffe9b8ff000)
            libxfreerdp-client.so.2 => /opt/remmina_devel/freerdp/lib64/libxfreerdp-client.so.2 (0x00007fc4b0547000)
            libXinerama.so.1 => /lib64/libXinerama.so.1 (0x00007fc4b0343000)
            libXcursor.so.1 => /lib64/libXcursor.so.1 (0x00007fc4b0138000)
            libXv.so.1 => /lib64/libXv.so.1 (0x00007fc4aff33000)
            libXi.so.6 => /lib64/libXi.so.6 (0x00007fc4afd22000)
            libXrender.so.1 => /lib64/libXrender.so.1 (0x00007fc4afb18000)
            libXfixes.so.3 => /lib64/libXfixes.so.3 (0x00007fc4af912000)
            libfreerdp-client.so.2 => /opt/remmina_devel/freerdp/lib64/libfreerdp-client.so.2 (0x00007fc4af631000)
            libcups.so.2 => /lib64/libcups.so.2 (0x00007fc4af3c8000)
            libpulse.so.0 => /lib64/libpulse.so.0 (0x00007fc4af17b000)
            libavcodec.so.56 => /lib64/libavcodec.so.56 (0x00007fc4ae06f000)
            libavutil.so.54 => /lib64/libavutil.so.54 (0x00007fc4ade11000)
            libgstreamer-1.0.so.0 => /lib64/libgstreamer-1.0.so.0 (0x00007fc4adb05000)
            libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007fc4ad7cd000)
            libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007fc4ad57d000)
            libgstbase-1.0.so.0 => /lib64/libgstbase-1.0.so.0 (0x00007fc4ad323000)
            libgstapp-1.0.so.0 => /lib64/libgstapp-1.0.so.0 (0x00007fc4ad115000)
            libgstvideo-1.0.so.0 => /lib64/libgstvideo-1.0.so.0 (0x00007fc4aceca000)
            libXext.so.6 => /lib64/libXext.so.6 (0x00007fc4accb8000)
            libasound.so.2 => /lib64/libasound.so.2 (0x00007fc4ac9ce000)
            libfreerdp.so.2 => /opt/remmina_devel/freerdp/lib64/libfreerdp.so.2 (0x00007fc4ac5fe000)
            libX11.so.6 => /lib64/libX11.so.6 (0x00007fc4ac2c0000)
            libxkbfile.so.1 => /lib64/libxkbfile.so.1 (0x00007fc4ac09a000)
            libwinpr.so.1 => /opt/remmina_devel/freerdp/lib64/libwinpr.so.1 (0x00007fc4abd92000)
            librt.so.1 => /lib64/librt.so.1 (0x00007fc4abb8a000)
            libssl.so.10 => /lib64/libssl.so.10 (0x00007fc4ab91c000)
            libcrypto.so.10 => /lib64/libcrypto.so.10 (0x00007fc4ab534000)
            libm.so.6 => /lib64/libm.so.6 (0x00007fc4ab232000)
            libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fc4ab015000)
            libdl.so.2 => /lib64/libdl.so.2 (0x00007fc4aae11000)
            libz.so.1 => /lib64/libz.so.1 (0x00007fc4aabfb000)
            libc.so.6 => /lib64/libc.so.6 (0x00007fc4aa839000)
            libgssapi_krb5.so.2 => /lib64/libgssapi_krb5.so.2 (0x00007fc4aa5ed000)
            libkrb5.so.3 => /lib64/libkrb5.so.3 (0x00007fc4aa307000)
            libk5crypto.so.3 => /lib64/libk5crypto.so.3 (0x00007fc4aa0d5000)
            libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007fc4a9ed1000)
            libavahi-common.so.3 => /lib64/libavahi-common.so.3 (0x00007fc4a9cc3000)
            libavahi-client.so.3 => /lib64/libavahi-client.so.3 (0x00007fc4a9ab2000)
            libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fc4a987b000)
            libjson-c.so.2 => /lib64/libjson-c.so.2 (0x00007fc4a966f000)
            libpulsecommon-6.0.so => /usr/lib64/pulseaudio/libpulsecommon-6.0.so (0x00007fc4a93f6000)
            libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00007fc4a91ae000)
            libcap.so.2 => /lib64/libcap.so.2 (0x00007fc4a8fa8000)
            libswresample.so.1 => /lib64/libswresample.so.1 (0x00007fc4a8d8e000)
            libva.so.1 => /lib64/libva.so.1 (0x00007fc4a8b78000)
            libxvidcore.so.4 => /lib64/libxvidcore.so.4 (0x00007fc4a8864000)
            libx265.so.51 => /lib64/libx265.so.51 (0x00007fc4a844f000)
            libx264.so.142 => /lib64/libx264.so.142 (0x00007fc4a80db000)
            libvpx.so.1 => /lib64/libvpx.so.1 (0x00007fc4a7d52000)
            libvorbisenc.so.2 => /lib64/libvorbisenc.so.2 (0x00007fc4a7883000)
            libvorbis.so.0 => /lib64/libvorbis.so.0 (0x00007fc4a7655000)
            libtheoraenc.so.1 => /lib64/libtheoraenc.so.1 (0x00007fc4a7427000)
            libtheoradec.so.1 => /lib64/libtheoradec.so.1 (0x00007fc4a7217000)
            libspeex.so.1 => /lib64/libspeex.so.1 (0x00007fc4a6ffe000)
            libschroedinger-1.0.so.0 => /lib64/libschroedinger-1.0.so.0 (0x00007fc4a6d31000)
            libopus.so.0 => /lib64/libopus.so.0 (0x00007fc4a6aef000)
            libopenjpeg.so.1 => /lib64/libopenjpeg.so.1 (0x00007fc4a68cb000)
            libmp3lame.so.0 => /lib64/libmp3lame.so.0 (0x00007fc4a6653000)
            libgsm.so.1 => /lib64/libgsm.so.1 (0x00007fc4a6447000)
            liblzma.so.5 => /lib64/liblzma.so.5 (0x00007fc4a6222000)
            libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00007fc4a601d000)
            libffi.so.6 => /lib64/libffi.so.6 (0x00007fc4a5e15000)
            liborc-0.4.so.0 => /lib64/liborc-0.4.so.0 (0x00007fc4a5b92000)
            /lib64/ld-linux-x86-64.so.2 (0x00005606a9676000)
            libxcb.so.1 => /lib64/libxcb.so.1 (0x00007fc4a5970000)
            libkrb5support.so.0 => /lib64/libkrb5support.so.0 (0x00007fc4a5760000)
            libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007fc4a555c000)
            libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fc4a5342000)
            libfreebl3.so => /lib64/libfreebl3.so (0x00007fc4a513e000)
            libX11-xcb.so.1 => /lib64/libX11-xcb.so.1 (0x00007fc4a4f3c000)
            libICE.so.6 => /lib64/libICE.so.6 (0x00007fc4a4d20000)
            libSM.so.6 => /lib64/libSM.so.6 (0x00007fc4a4b17000)
            libXtst.so.6 => /lib64/libXtst.so.6 (0x00007fc4a4911000)
            libsystemd.so.0 => /lib64/libsystemd.so.0 (0x00007fc4a48e9000)
            libwrap.so.0 => /lib64/libwrap.so.0 (0x00007fc4a46dd000)
            libsndfile.so.1 => /lib64/libsndfile.so.1 (0x00007fc4a447e000)
            libasyncns.so.0 => /lib64/libasyncns.so.0 (0x00007fc4a4278000)
            libattr.so.1 => /lib64/libattr.so.1 (0x00007fc4a4072000)
            libsoxr.so.0 => /lib64/libsoxr.so.0 (0x00007fc4a3e0f000)
            libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007fc4a3b07000)
            libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fc4a38f0000)
            libogg.so.0 => /usr/lib64/libogg.so.0 (0x00007fc4a36e9000)
            libXau.so.6 => /lib64/libXau.so.6 (0x00007fc4a34e4000)
            libselinux.so.1 => /lib64/libselinux.so.1 (0x00007fc4a32bf000)
            libuuid.so.1 => /lib64/libuuid.so.1 (0x00007fc4a30ba000)
            libgcrypt.so.11 => /lib64/libgcrypt.so.11 (0x00007fc4a2e38000)
            libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x00007fc4a2c33000)
            libdw.so.1 => /lib64/libdw.so.1 (0x00007fc4a29ec000)
            libnsl.so.1 => /lib64/libnsl.so.1 (0x00007fc4a27d2000)
            libFLAC.so.8 => /lib64/libFLAC.so.8 (0x00007fc4a258d000)
            libgomp.so.1 => /lib64/libgomp.so.1 (0x00007fc4a2375000)
            libpcre.so.1 => /lib64/libpcre.so.1 (0x00007fc4a2114000)
            libelf.so.1 => /lib64/libelf.so.1 (0x00007fc4a1efd000)
            libbz2.so.1 => /lib64/libbz2.so.1 (0x00007fc4a1ced000)

  • You still have an old version of freerdp installed.

    rpm -e libwinpr libwinpr-devel freerdp freerdp-libs freerdp-plugins remmina remmina-devel remmina-plugins-gnome remmina-plugins-nx remmina-plugins-rdp remmina-plugins-telepathy remmina-plugins-vnc remmina-plugins-xdmcp

    Then start from zero with the fedora wiki.

  • Hi Antenore,

    None of the packages above is installed on my system. It it still failing when I install this update.

    [~]# rpm -e libwinpr libwinpr-devel freerdp freerdp-libs freerdp-plugins remmina remmina-devel remmina-plugins-gnome remmina-plugins-nx remmina-plugins-rdp remmina-plugins-telepathy remmina-plugins-vnc remmina-plugins-xdmcp
    error: package libwinpr is not installed
    error: package libwinpr-devel is not installed
    error: package freerdp is not installed
    error: package freerdp-libs is not installed
    error: package freerdp-plugins is not installed
    error: package remmina is not installed
    error: package remmina-devel is not installed
    error: package remmina-plugins-gnome is not installed
    error: package remmina-plugins-nx is not installed
    error: package remmina-plugins-rdp is not installed
    error: package remmina-plugins-telepathy is not installed
    error: package remmina-plugins-vnc is not installed
    error: package remmina-plugins-xdmcp is not installed
    [~]#
    [~]# rpm -qa | grep freerdp
    [~]#
    [~]# xfreerdp –version
    This is FreeRDP version 2.0.0-dev (git 66ae3f2)


    — Found LIBSECRET: /usr/include/libsecret-1;/usr/include/glib-2.0;/usr/lib64/glib-2.0/include
    CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
    Please set them or make sure they are set and tested correctly in the CMake files:
    WINPR_INCLUDE_DIR
    used as include directory in directory /root/remmina_devel-rcgit9/Remmina/remmina-plugins/rdp

    — Configuring incomplete, errors occurred!

Leave a Reply

Your email address will not be published. Required fields are marked *